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TopLineDesigner

Online Help 

TopLine Designer is an add-on product for ACT! by Sage that gives you the ability to add new custom 
sub-entities and it provides a framework for designing screens, relationships and calculations for those 
sub-entities. A sub-entity is another word for a sub-table. It is a table that must be related to a specific 
Contact, Company, or Group. Entities such as Contacts, Companies, and Groups are called Top-Level 
Entities. Top-Level Entities cannot be created using this tool. 
TopLine Designer has two major components. There is the Administration component and the End User
component.

Welcome 

Welcome to the TopLineDesigner online help system. Browse through the help 
pages by clicking on the links above or selecting pages in the table of contents. 
To quickly find specific product information, enter search criteria in the search 
box above and click the search button.

Most popular pages 

● Welcome 
● System Requirements 
● Installation 
● Obtaining Installation Program 
● Features 
● Create a New Table 
● Administrator Functions 
● Displaying Current Version 
● Running Installation 
● Using List View 
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Home > Welcome > Features 

TopLine Designer Features
For the ACT! Windows user: 

View tables interactively, go to the corresponding contact, company or group.  

Drill down on custom tables to access the detail view.

Create a contact, company or group lookup.

Click to sort or filter in the list view.

Create robust queries and apply date ranges.

Perform advanced calculations among fields and in the list view.

Create activities or histories based on custom-table fields. 

Generate email notifications.

Modify field appearance (auto hide, change color) based on conditions.

Drag and drop fields to group and organize your custom lists.

Organize, sort or query your documents.

Export list views to MS Excel.

Merge custom-table fields into MS Word to create documents and templates. 

Synchronize your customizations and data.

Integrate with TopLine Dash for enhanced reporting and graphical views.

Automate your Excel or PDF custom table reports using TopLine Dash Alerts.

For the ACT! Web user: 

View, edit or create table content interactively.  

Drill down on custom tables to access the detail view.

Click to sort in the list view.

For the ACT! administrator: 

Build relationships between contact, company or group tables.

Build relationships between custom tables allowing for parent-child relationships. 

Build screens with one or more embedded custom tables.

Create new fields and field calculations.

Use scripting to perform advanced calculations, task automation and to vary field appearance based on conditions (auto hide, change color 
and more).

Design, color code and embed your layout screens.

Use snippets and scripting to add new functionality easily in .NET.

Import/export the TopLine Designer customizations.
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Import data into your custom tables from any OLEDB-compatible data source;  CSV files; Excel spreadsheets; or SQL, Oracle or MS Access 
databases.

Synchronize and back up custom tables and customizations.

Protect your database. Only the ACT! Administrator can perform customizations. 

See also
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This section will demonstrate how to:

● Install TopLine Designer for ACT! 
● Activiate TopLine Designer with serial number 
● Configure TopLine Designer to work with ACT! for Web 
● Obtain Designer Updates 
● Display the current version and serial number of Designer

Articles in this section

See also
Welcome 
Administrator Functions 
End User Functions 
Windows vs Web Functionality 
Integration with TopLine Dash 
FAQ 
Videos 
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Home > Installation > System Requirements 

System Requirements
TopLine Designer requires ACT! 2008 version 10.0.2 or higher.  ACT! 2009 is also supported.  You must be an ACT! Administrator in order to make 
schema changes.  Schema changes cannot be made on a remote database.

See also

Obtaining Installation Program 
Running Installation 
Activation 
Web License Manager 
Obtaining Updates 
Displaying Current Version 
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Obtaining Installation Program
If you have a previous version of TopLine Designer installed, you must first uninstall it using Add/Remove Programs (or Programs and Features in 
Windows Vista) from the Control Panel.

Direct your web browser to http://www.toplineresults.com/products/downloads.htm in order to download the latest version.  Select TopLine Designer 
for the version of ACT! currently installed.  When prompted, select Run to install TopLine Designer.

After the software has been installed, you will see additional menu items in ACT!.

See also

System Requirements 
Running Installation 
Activation 
Web License Manager 
Obtaining Updates 
Displaying Current Version 
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Home > Installation > Running Installation 

Running Installation
Close ACT! before installing TopLine Designer.

1. Double click on the installer MSI (usually named TopLineDesignerX.X.X.X.msi, where X.X.X.X indicates the current version) to start the Windows 
Installer.

 
2. On the TopLine Designer Setup Wizard screen, click Next.

 
3. Agree to the License Agreement and click Next.
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4. Accept the default installation folder, or change with the Browse button.  Allow Everyone to access TopLine Designer and click Next. 

 
5. Confirm the installation and click Next.
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6. Wait for the progress bar to complete, and click Close to finish the installation.

TopLine Designer is a plugin to ACT! and will only be visible inside the ACT! program's user interface.

See also

System Requirements 
Obtaining Installation Program 
Activation 
Web License Manager 
Obtaining Updates 
Displaying Current Version 
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Activation
Upon logging into an ACT! database after installing TopLine Designer, the TopLine Designer Activation window will appear.  TopLine Designer is available 
in a fully functional 30 day trial mode, starting from the day of installation.  The Activation window will display how many day are remaining in the trial.  
Upon expiration of the trial, all TopLine Designer data or screens will be inaccessible, but they will remain in the database. 

1. To activate TopLine Designer with a serial number, click on the lock icon.

 
2. Type the serial number into the field labeled Serial Number.

 
3. If an internet connection is available, click Next to attempt to activate with our servers.  If a connection is successful, the My Record information 

will be displayed in the Registration boxes.  Confirm this information and click Next.  (Proceed to step 8)
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4. If an internet connection is not available, click on the Activate Manually button.

 
5. Call TopLine Results at the phone number provided, and provide them the contents of Box A and Box B.  They will in turn provide you with the 

unlock code for Box C.
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6. An unlock code can be generated without calling TopLine Results by clicking on the Unlock Code by Webpage link in Step 3.   

 
7. A browser window will be opened.  Enter the registration information into the boxes and click the Get Unlock Code button.   
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The unlock code will appear on the next page.

 
8. Enter the unlock code in Box C and click Next.

 
9. Click Finish to complete the activation process and start ACT!
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See also

System Requirements 
Obtaining Installation Program 
Running Installation 
Web License Manager 
Obtaining Updates 
Displaying Current Version 

 
Installation . 14

 
TopLineDesigner



Home > Installation > Web License Manager 

Web License Manager
TopLine Designer data and screens are available to ACT! for Web users, but additional setup is required.  The ACT for Web users must be designated to 
use TopLine Designer and must be less or equal to the total number of TopLine Designer licenses.

The following steps are performed using the TopLine Designer for Web License Manager, which can be found under the TopLine Results program group 
from the Start Menu.

Articles in this section

See also

System Requirements 
Obtaining Installation Program 
Running Installation 
Activation 
Obtaining Updates 
Displaying Current Version 
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Initial Setup
The TopLine Designer for Web files must be installed in the same virtual folder as your ACT for Web program.

1. Start the Designer for Web License Manager from the Start Menu, under the TopLine Results program group.

 
2. On the startup screen, click the Initial Setup icon.

 
3. Select the Web Server Path.  For a typical ACT for Web installation, this will be the Default Web Server Instance and the APFW Virtual 

Directory. 
4. Click the Next button.
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5. Click the Install TopLine Designer for Web button.

 
6. A progress bar will appear at the bottom of the window.  Upon completion, a Success dialog box will appear.  Click Ok.

 
7. The Designer for Web License Manager will display a Reset Web Server dialog box to restart the local webserver.  Click Yes to proceed. 
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8. A progress bar will appear at the bottom of the window.  Upon completion, a Success dialog box will appear.  Click Ok.

 
9. Click Next 

10. Following the Initial Setup, a window will appear to perform another Initial Setup or continue to the next setup step. 
11. Click Finish to return to the Main License Manager screen.

See also

Adding Serial Numbers 
Associating ACT Users 
Viewing / Exporting Configuration 
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Adding Serial Numbers
Once the Initial Setup has completed and the Designer for Web files have been installed, the TopLine Designer serial number must be entered into the 
License Manager for the ACT for Web application.

1. On the startup screen, click the Add Serial Numbers button

 
2. Enter the TopLine Designer serial number into the box, and press the Register Serial Number button.

 
3. Once the serial number has been confirmed, it will be displayed in the lower section of the screen. 
4. Click Next
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5. Following the Initial Setup, a window will appear to perform another Initial Setup or continue to the next setup step. 
6. Click Finish to return to the Main License Manager screen.

The lower section of the screen will display all TopLine Designer serial numbers, the number of licenses associated with that serial number and number of 
licenses assigned to users.

The serial number can be removed from the License Manager by highlighting the serial number in the lower section of the screen and pressing the 
Remove button.

See also

Initial Setup 
Associating ACT Users 
Viewing / Exporting Configuration 
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Associating ACT Users
Any ACT user must be designated to be allowed to see TopLine Designer data and screens.  Multiple users can be associated with multiple databases 
using TopLine Designer.

1. On the startup screen, click the Associate ACT! Users button

 
2. Click on the Select ACT! Database button, browse to find the ACT! database and press Open.

 
3. Enter the ACT! username and password of the ACT! Administrator, then click Next.
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4. Select the TopLine Designer serial number (which has remaining, unused licenses)  
5. Select the ACT! to have TopLine Designer access (by default, only active ACT! users will be displayed.  To view ALL users, click the Include 

Inactive Users checkbox) 
6. Press the Associate ACT! User with Serial Number button to allow the ACT user to have Designer access.

 
7. Click Next 
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8. Following the Initial Setup, a window will appear to perform another Initial Setup or continue to the next setup step. 
9. Click Finish to return to the Main License Manager screen.

See also

Initial Setup 
Adding Serial Numbers 
Viewing / Exporting Configuration 
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Obtaining Updates
Updates are provided on the TopLine Results website:  http://www.toplineresults.com/products/downloads.htm 

TopLine Designer installs an Update Checker in the Program Groups.

1. Start the TopLine Designer Update from the Start Menu under the TopLine Results program group.

 
2. Status bars will show the Update program connecting to the TopLine server. 
3. Click on the Check button. 

 
4. If an update is available......

See also

System Requirements 
Obtaining Installation Program 
Running Installation 
Activation 
Web License Manager 
Displaying Current Version 
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Home > Installation > Displaying Current Version 

About TopLine Designer - Finding the version you are on... 

 

1. Open ACT! 
2. Click on the Tools menu and select TopLine Designer - Manager... 

   
3. If using a Publishing or Non-Publishing, the Entity Manager window will appear.  Click on the About button in the lower left hand corner. 

 
4. If using a Remote database, an dialog box will appear with a message about the Entity Manager being unavailable.  Click Ok to see the version 

information.
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5. Version and Serial # will be displayed

See also

System Requirements 
Obtaining Installation Program 
Running Installation 
Activation 
Web License Manager 
Obtaining Updates 
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With TopLine Designer, the Administrator can:

● Build relationships between contact, company or group tables. 
● Build relationships between custom tables allowing for parent-child relationships.  
● Build screens with one or more embedded custom tables. 
● Create new fields and field calculations. 
● Use scripting to perform advanced calculations, task automation and to vary field appearance based on conditions (auto 

hide, change color and more). 
● Design, color code and embed your layout screens. 
● Use snippets and scripting to add new functionality easily in .NET. 
● Import/export the TopLine Designer customizations. 
● Import data into your custom tables from any OLEDB-compatible data source, CSV file, Excel spreadsheet; or SQL, 

Oracle, or MS Access database. 
● Synchronize and back up custom tables and customizations. 
● Protect your database. Only the ACT! Administrator can perform customizations. 

Articles in this section

See also

Welcome 
Installation 
End User Functions 
Windows vs Web Functionality 
Integration with TopLine Dash 
FAQ 
Videos 
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Applying Preconfigured Template
The fastest way to get started is to apply one of the built-in templates provided.  This will automatically add new tables and fields to your database to help you get started. 

Please note:  It is strongly recommended that you back up your database before you continue.

1. Open ACT! 
2. Click on the Tools menu and select TopLine Designer - Manager... 

   
3. Click on the Database Template Wizard link 
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4. Read the warning and click Next 

 
5. Select a preconfigured template from the categories listed. 
6. Click on the active Apply Selected Template link.  NOTE: The template will not be applied until this link is clicked.
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7. An ImportLog will open and show the template's status. 
8. Click Finish to close the Apply Database Template window.

See also
Managing Tables 
Managing Custom Table Screens 
Migrating Data 
Importing Data 
Managing Word Templates 
Managing Schema 
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Managing Tables
The Administrator can perform the following operations on a master database with TopLine Designer:  

● Create a new custom table 
● Edit the attributes of an existing custom table 
● Delete an existing custom table 
● Define relationships between custom tables 
● Create new custom table fields 
● Edit existing custom table fields 
● Delete exisitng custom table fields 
● Assign field security to custom table fields 

 

Articles in this section

See also

Applying Preconfigured Template 
Managing Custom Table Screens 
Migrating Data 
Importing Data 
Managing Word Templates 
Managing Schema 
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Create a New Table
Creating a new sub-entity is easy. 

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Click the Add Table link
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4. A wizard will display to guide you through the process of creating a new table.  Click Next to begin.

 
5. Type the name of the table into the filed under Table Name.  The table name is usually plural since multiple records will be stored within this table. 

Below, you will select the ACT! primary entities you want to link this table.  All custom sub-entities must be linked to one or more primary entities in ACT!. 
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6. Table Properties 

1. Layout Tabs
Placing a checkmark in these boxes will add a new tab to the contact, company or group layout for this table. 

2. Lookup Menu
Selecting Yes will add a new menu item to the Lookup menu which allows you to perform a lookup on records in this table.  The result will be a lookup 
of contacts, companies or groups. 

3. View Menu
Selecting Yes will add a new menu item to the View menu.  This allows you to view and filter a list of all of the records in this table. 

 
7. Click the Finish button to create your table.

 
Administrator Functions . 34

 
TopLineDesigner



You will now see the fields for the new table on the screen.

 

See also

Editing an Existing Table 
Deleting an Existing Table 
Creating Fields 
Editing Fields 
Deleting Fields 
Assigning Field Security 
Defining Relationships 
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Editing an Existing Table
Editing an existing custom table is easy.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Select the appropriate custom table from the dropdown and click on the Edit Table link

 
Administrator Functions . 36

 
TopLineDesigner



 
4. A wizard will display to guide you through the process of editing the table.  Click Next to begin.

 
5. The table name and ACT linked entities cannot be modified for existing tables.

 
37 . Administrator Functions

 
TopLineDesigner



 
6. Table Properties can be modified. 

1. Layout Tabs
Placing a check mark in these boxes will add a new tab to the contact, company or group layout for this table. 

2. Lookup Menu
Selecting Yes will add a new menu item to the Lookup menu which allows you to perform a lookup on records in this table.  The result will be a lookup 
of contacts, companies or groups. 

3. View Menu
Selecting Yes will add a new menu item to the View menu.  This allows you to view and filter a list of all of the records in this table. 

 
7. Click the Finish button to modify your table.
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See also

Create a New Table 
Deleting an Existing Table 
Creating Fields 
Editing Fields 
Deleting Fields 
Assigning Field Security 
Defining Relationships 
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Deleting an Existing Table
Deleting an existing custom table is easy.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Select the appropriate custom table from the dropdown and click on the Delete Table link.
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4. A warning will appear that all data will be deleted and cannot be undone.  Click Yes to continue.

 
5. A confirmation box will appear.  Click Yes to actually delete the custom table.

Should an error occur while deleting a table, the following procedure should be used:
1.    Start ACTDIAG
2.    Detach the database from SQL.
3.    Close ACTDIAG
4.    Start ACT
5.    Open the database using the .ADF file to have SQL repair the database
6.    Delete the custom table again

See also

Create a New Table 
Editing an Existing Table 
Creating Fields 
Editing Fields 
Deleting Fields 
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Assigning Field Security 
Defining Relationships 
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Creating Fields
Numerous fields can be created in a custom table.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Select the appropriate custom table from the dropdown and click on the Add Field link
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4. Enter a name for the new field.  Select the field type from the choices of: 

1. Annual Event 
2. Character 
3. Currency 
4. Date 
5. DateTime 
6. Decimal 
7. Initial Caps 
8. Lowercase 
9. Memo 

10. Number 
11. Time 
12. Uppercase 
13. URL 
14. Yes/No

5. The checkbox of Allow Blank indicates whether the field is required. 
6. A dropdown list can be assigned to the field (depending on the type).  Designer allows you to access the dropdown management screen from this area.  
7. An additional screen may appear when using dropdowns to Limit to List, Allow Multi-Select, Show Descriptions and Enable Type Ahead, just like typical ACT fields. 
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8. An additional screen may appear depending on field type for Default Value and Field Length.

 
9. Click Finish to create the new field and return the Define Fields screen.

See also

Create a New Table 
Editing an Existing Table 
Deleting an Existing Table 
Editing Fields 
Deleting Fields 
Assigning Field Security 
Defining Relationships 
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Editing Fields
Like typical ACT! fields, custom table fields can be edited and have their properties changed.  NOTE:  System custom table fields cannot be edited. 

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Select the appropriate custom table from the dropdown, highlight the desired custom field and click the Edit Field link
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4. Make the appropriate changes and click Finish to return to the Define Fields screen.

See also

Create a New Table 
Editing an Existing Table 
Deleting an Existing Table 
Creating Fields 
Deleting Fields 
Assigning Field Security 
Defining Relationships 
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Deleting Fields
Just like typical ACT fields, custom table fields can be deleted.  NOTE:  System custom table fields cannot be deleted.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Select the appropriate custom table from the dropdown, highlight the desired custom field and click on the Delete Field link
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4. A confirmation dialog will appear, warning that deletions cannot be undone.  Press Yes to delete field and return to Define Fields screen.

See also

Create a New Table 
Editing an Existing Table 
Deleting an Existing Table 
Creating Fields 
Editing Fields 
Assigning Field Security 
Defining Relationships 
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Assigning Field Security
Like typical ACT! fields, custom table fields can have field level security, both default and by individual user.  NOTE:  System custom table fields cannot be edited. 

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Select the appropriate custom table from the dropdown, highlight the desired custom field and click the Field Security link.
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4. Set the default permission from: 

1. Full Access - allowed to view and edit  
2. Read-Only - allowed to view  
3. No-Access - blank field regardless if value present 

5. The default permission can be overwritten for an individual user by highlighting the user and pressing the Edit button.
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6. Choose the appropriate access level and press OK.

 
7. Press OK to return to the Define Fields screen.

See also

Create a New Table 
Editing an Existing Table 
Deleting an Existing Table 
Creating Fields 
Editing Fields 
Deleting Fields 
Defining Relationships 
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Defining Relationships
By default, a relationship is established between Contacts, Companies and Groups with the nearly created Custom Table.  One record in the Parent (i.e. 
Contacts), can have many Child records (i.e. Custom Table) associated with it.  This type of relationship can also be created between two custom 
tables.  For example, a custom table could contain Service Contracts and a second custom table could contain Service Tickets.  There can be several 
Service Tickets associated with each Service Contract.  TopLine Designer allows these types of relationships to be built. 

See also

Create a New Table 
Editing an Existing Table 
Deleting an Existing Table 
Creating Fields 
Editing Fields 
Deleting Fields 
Assigning Field Security 
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Add Relationship
To build a new relationship between existing custom tables is easy.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Click the Define Relationship link.
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4. Click the Add Relationship link.

 
5. The Relationship Creation Wizard will appear.  Click Next to begin.
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6. Select the Parent Table from the dropdown and the Child Table from the dropdown.  Click Next.

 
7. Assign a name to the newly created key which will link the two fields. This Child Table field will hold the special key linking the two tables. Click Next. 
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8. Select the field in the Parent table which will identify it from the Child table or create a brand new field.  Click Next.

 
9. Give the relationship a unique name. Click Next.
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10. Click Finish to create the relationship.

 
11. Click OK to return to the Define Fields screen.

See also

Edit Relationship 
Delete Relationship 
Relationship with Activites and Opps 
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Home > Administrator Functions > Managing Tables > Defining Relationships > Edit Relationship 

Edit Relationship
To edit a relationship between existing custom tables is easy.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Click on the Define Relationship link.
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4. Select a Table for which it is the Child, highlight the relationship, and click the Edit Relationship link.

 
5. The Relationship Creation Wizard will begin.  Click Next to start.
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6. The Parent and Child tables cannot be changed.  Chick Next.

 
7. Modify the existing properties of the relationship as necessary. 
8. Click OK to return to the Define Fields screen.

See also

Add Relationship 
Delete Relationship 
Relationship with Activites and Opps 

 
61 . Administrator Functions

 
TopLineDesigner



Home > Administrator Functions > Managing Tables > Defining Relationships > Delete Relationship 

Delete Relationship
To delete a relationship between existing custom tables is easy.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

 
3. Click on the Define Relationship link.
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4. Select a Table for which it is the Child, highlight the relationship, and click on the Delete Relationship link.

 
5. A confirmation dialog box will appear warning that the action cannot be undone.  Click Yes to delete the relationship.

 
6. Click OK to return to the Define Fields screen.

NOTE:  No data in either the Parent or Child will be deleted or altered with the deletion of the relationship.

See also
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Add Relationship 
Edit Relationship 
Relationship with Activites and Opps 
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Home > Administrator Functions > Managing Tables > Defining Relationships > Relationship with Activites and Opps 

Relationship with Activites and Opps
Activities and Opportunities can be associated or related to the individual Custom Table records by creating a relationship between the two tables. 

Follow the steps under Add Relationship 

Parent Table = Activity (or Opportunity)
Child Table = Custom Table
Foreign Key = 
Display Key =

See also

Add Relationship 
Edit Relationship 
Delete Relationship 
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Managing Custom Table Screens
The Administrator can perform the following operations on a master database with TopLine Designer:  

● Create a new custom table screen 
● Edit the attributes of an existing custom table screen 
● Delete an existing custom table screen 
● Assign VB.NET scripts (snippets) to perform custom functions 

Articles in this section

See also

Applying Preconfigured Template 
Managing Tables 
Migrating Data 
Importing Data 
Managing Word Templates 
Managing Schema 

 
Adding a New Screen 

 
Changing Screen 

Properties 

 
Deleting a Screen 

 
Designing Screen 

 
Editing Screen Scripts 
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Home > Administrator Functions > Managing Custom Table Screens > Adding a New Screen 

Adding a New Screen
A blank, default screen will automatically be created upon custom table generation. However, creating a new custom table screen is easy. 

1. Open ACT! 
2. Click on the Tools menu and select Design Custom Table Screens...

 
3. Select the custom table and click on the Add Screen link.
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4. Type the name of the new screen, set the maximum number of rows and columns, and click Next.

 
5. Select either Horizontal or Vertical tab order, then click Next

 
Administrator Functions . 68

 
TopLineDesigner



 
6. Click Finish to create the new blank screen and return to the Define Screens window.

See also

Changing Screen Properties 
Deleting a Screen 
Designing Screen 
Editing Screen Scripts 
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Home > Administrator Functions > Managing Custom Table Screens > Changing Screen Properties 

Changing Screen Properties
A blank, default screen will automatically be created upon custom table generation, but creating a new custom table screen is easy. 

1. Open ACT! 
2. Click on the Tools menu and select Design Custom Table Screens...

 
3. Select the custom table and click the Screen Properties link.
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4. Change the name of the new screen, set the maximum number of rows and columns, and click Next.

 
5. Select either Horizontal or Vertical tab order, click Next.
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6. Click Finish to commit the changes and return to the Define Screens window.

See also

Adding a New Screen 
Deleting a Screen 
Designing Screen 
Editing Screen Scripts 
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Home > Administrator Functions > Managing Custom Table Screens > Deleting a Screen 

Deleting a Screen
A custom table screen can be deleted at any time, but just ensure that no relationship is using the custom table screen.

1. Open ACT! 
2. Click on the Tools menu and select Design Custom Table Screens...

 
3. Select the custom table and screen, click the Delete Screen link.
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4. Click YES to confirm the deletion.

 
5. Return to the Define Screens window.

See also

Adding a New Screen 
Changing Screen Properties 
Designing Screen 
Editing Screen Scripts 
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Home > Administrator Functions > Managing Custom Table Screens > Designing Screen 

Designing Screen
Place fields on the blank screen by:

1. Open ACT! 
2. Click on the Tools menu and select Design Custom Table Screens...

 
3. Select the custom table and click the Design Screen link.

 
4. The Custom Entity Screen will appear.
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5. The Custom Table Screen is now ready to add fields, images and scripts.

Articles in this section

See also

Adding a New Screen 
Changing Screen Properties 
Deleting a Screen 
Editing Screen Scripts 

 
Adding Fields 

 
Moving Fields 

 
Adding Static Images 

 
Deleting Fields 

 
Modifying Field 

Attributes 

 
Changing Screen Color 
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Home > Administrator Functions > Managing Custom Table Screens > Designing Screen > Adding Fields 

Adding Fields
Fields from the custom table or a grid containing all the immediate child records may be displayed on the custom table screen. 

1. Click the Add Field button.

 
2. Select either a field or child table grid.

 
3. The field will appear in the next available section of the screen.

See also
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Moving Fields 
Adding Static Images 
Deleting Fields 
Modifying Field Attributes 
Changing Screen Color 
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Home > Administrator Functions > Managing Custom Table Screens > Designing Screen > Moving Fields 

Moving Fields
Fields may be moved to any section of the custom table screen grid using the arrow keys or the arrow buttons in the upper right hand corner of the TopLine Designer window. 

1. Select the field on the custom table screen. 

 
2. Use the arrow keys or the arrow buttons to move the field to the next available section or swap with existing field.

See also
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Adding Fields 
Adding Static Images 
Deleting Fields 
Modifying Field Attributes 
Changing Screen Color 
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Home > Administrator Functions > Managing Custom Table Screens > Designing Screen > Adding Static Images 

Adding Static Images
Static images, such as corporate logos, can be added to the custom table screen.

1. Press the Add Image button.

 
2. From the Open Dialog box, browse to find the image.  Only BMP, JPG, GIF and PNG images are allowed.  The image cannot be resized once it has been added to the screen. 

 
3. The image will be placed in the first available section.
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See also

Adding Fields 
Moving Fields 
Deleting Fields 
Modifying Field Attributes 
Changing Screen Color 
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Home > Administrator Functions > Managing Custom Table Screens > Designing Screen > Deleting Fields 

Deleting Fields
Fields can be removed from the custom table screen.

1. Select the field on the custom table screen.

 
2. Click the Delete Field button.

 
3. The field is removed.
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See also

Adding Fields 
Moving Fields 
Adding Static Images 
Modifying Field Attributes 
Changing Screen Color 
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Home > Administrator Functions > Managing Custom Table Screens > Designing Screen > Modifying Field Attributes 

Modifying Field Attributes
Field attributes define how the field is displayed on the screen.

1. Select the field on the custom table screen.

 
2. Click the Edit Field Properties button. 
3. Modify the Field Properties as needed. 

1. Label Text (always appears left of the field) 
2. Field Width (in pixels) 
3. Field Height (only valid for Memo Fields and Grids) 
4. Row Span 
5. Column Span 
6. Label Color 
7. Field Color 
8. Field Text Color

4. Click Close to apply the changes.
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See also

Adding Fields 
Moving Fields 
Adding Static Images 
Deleting Fields 
Changing Screen Color 
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Home > Administrator Functions > Managing Custom Table Screens > Designing Screen > Changing Screen Color 

Changing Screen Color
The background color of the Custom Table Screen can be changed, but gradients and tiled graphic files cannot be used.

1. Click on the color swatch below Screen Color in the lower right hand corner of the window.

 
2. Choose either a Basic Color or Define a Custom Color. 
3. Click OK to apply the color to the screen.
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NOTE:  Custom Colors are not remembered for future use.

See also

Adding Fields 
Moving Fields 
Adding Static Images 
Deleting Fields 
Modifying Field Attributes 
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Home > Administrator Functions > Managing Custom Table Screens > Editing Screen Scripts 

Editing Screen Scripts
TopLine Designer (along with ACT) can use Visual Basic Scripting to help manipulate ACT! data and automate tasks. 

1. Open ACT! 
2. Click on the Tools menu and select Design Custom Table Screens...

 
3. Select the custom table and click the Design Screen link.

 
4. The Custom Entity Screen will appear.
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5. Press the Modify Scripting button to enter the Script Editor.

Articles in this section

See also

 
Scripting Events 

 
Using Snippets 

 
Scripting Assistance 
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Home > Administrator Functions > Managing Custom Table Screens > Editing Screen Scripts > Scripting Events 

Scripting Events
There are 3 events in a TopLine Designer Custom Table Screen that can be used to lauch a script.

1. OnLoad = When the screen is first displayed. 
2. OnBeforeClose = When the screen is closed. 
3. OnFieldChange = When a field's value is changed.

See also

Using Snippets 
Scripting Assistance 
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Home > Administrator Functions > Managing Custom Table Screens > Editing Screen Scripts > Using Snippets 

Using Snippets
TopLine Designer include several "sniplets" to help the ACT! Administrator perform several common functions.  To use a snippet: 

1. From the Script Designer, click on Insert Snippet.

 
2. Select the appropriate snippet, fill in the wizard fields and assign the snippet to an event.

 
93 . Administrator Functions

 
TopLineDesigner



 
3. The code in inserted into the Script Editor

 
4. Click OK to closethe Script Editor and have the Visual Basic code checked 

See also

Scripting Events 
Scripting Assistance 
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Home > Administrator Functions > Managing Custom Table Screens > Editing Screen Scripts > Scripting Assistance 

Scripting Assistance
The TopLine Designer Script Editor includes a help file which explains all the current snippets and give other ACT methods for advanced scripting.  TopLine Results also offers Scripting 
Consulting via out estore at http://store.toplineresults.com. 

1. Click on the Help menu item from the Script Editor

 
2. The Help File will explain other ACT methods which can be used in more advanced scripting.

See also

 
95 . Administrator Functions

 
TopLineDesigner

http://store.toplineresults.com/


Scripting Events 
Using Snippets 
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Migrating Data
Migrating data allows the administrator to copy data from existing contact, company or group fields into new custom table records.  For example, contact data such as: 

1. Open ACT! 
2. Click on the Tools menu and select TopLine Designer - Manager... 

   
3. Click the desired Custom Tables for migration and press the Migrate from ACT! button.
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4. A Migrate Data from ACT! window will appear.  Every field in the custom table will appear along with a drop down.  Select the appropriate contact field to map 

data.  Fields which are not mapped will remain blank and the Record Manager will be the current user.

 
5. Click the OK button.  A confirmation dialog box will appear.  Click Yes and watch the progress bar.  
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When completed, a dialog box will ask if you would like to perform another migrate. Repeat for all additional rows.

 
6. Click OK to close the Define Fields Window.

NOTE: Rows for which all data is empty will not create new Custom Table records.

See also

Applying Preconfigured Template 
Managing Tables 
Managing Custom Table Screens 
Importing Data 
Managing Word Templates 
Managing Schema 
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Home > Administrator Functions > Importing Data 

Importing Data
Data can be imported into the Custom Tables from CSV files or other data sources.  The source data must have one (and only one) field to match the parent table (i.e. Contact, Company, Group, or 
other Custom Table).

1. Open ACT! 
2. Click on the Tools menu and select TopLine Designer - Manager... 

   
3. Click the desired Custom Tables for migration and press the Import Data button.
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4. The Import Wizard will begin.  Click Next.

 
5. Select a CSV or other datasource.  This example will be with a CSV file.  Click Next to continue.
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6. Create a New Import profile (like this example) or load an existing data map.  Select the Custom Table to import into and click Next. 

 
7. Map the Datasource file to the ACT! field to find the proper Parent entity.  In this example, the custom table will be matched to the Contact entity by the Contact field in the CSV file to the 

Contact field in ACT!  Click Next.
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8. First, map the Source fields to the Custom Table ACT! fields.  Select the Dupe Check box to have TopLine Designer check for duplicates based upon that field prior to importing.  For this 

example, Designer will not import the new data if the current contact has another record with the same Model Number.

 
9. If a duplicate is found, have Designer update (replace) the matching record or skip the matching record.  The number of records imported can be restricted to test the import settings.  All 

import settings can be saved for future imports.  Click Finish to begin the actual import.
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10. An import log will be shown displaying the progress of the import.

 
11. The data is imported.  Notice the records with Company=(none) were updated because Company was not in the source data and was not matched. 

See also

Applying Preconfigured Template 
Managing Tables 
Managing Custom Table Screens 
Migrating Data 
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Managing Word Templates 
Managing Schema 
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Home > Administrator Functions > Managing Word Templates 

Managing Word Templates
The administrator can manage Word Templates which use Custom Table fields.

Creating a New Template 

To create a new template, navigate to a tab that contains a record to merge and right click on a record.

This will launch a new Microsoft Word document along with a popup window titled Merge Fields.

You can now create your document using Microsoft Word.  When you want to insert a merged field, place your cursor in Microsoft Word in the location 
where you want the merged field to be inserted and double click on the field in the popup window. 

Click on the Entity dropdown to select fields from different tables.  The choices are:

● [Custom Table] – This is the primary table that you will be merging.  
● My Record – This will insert contact fields.  It will merge with data from your My Record contact.  
● Contact – This will insert contact fields.  It will merge with data from the selected record’s parent contact.  
● Company – This will insert contact fields.  It will merge with data from the selected record’s parent company.  
● Group – This will insert group fields.  It will merge with data from the selected record’s parent group. 

Not all of these options are always available.  

Once you have created your document, you must click on the Save and Close button on the popup window to save your template.  Do not use the Save 
feature in Microsoft Word.  Give the template a unique name.

Editing an Existing Template 

To edit an existing template, navigate to a tab that contains a record to merge.  Right click, choose Write and choose Edit Template. 

Choose the template you want to edit from the Open File box and click Open.  The template must have been created using the procedure indicated in 
the above section.  You cannot edit a template that was created manually in Microsoft Word or in ACT!

The procedure for editing a template is the same as creating a new template.  When finished, click on the Save and Close button.  Do not use the 
Microsoft Word Save function.  After clicking on Save and Close, you will be asked if you want to update the template.  If you select Yes, the document 
will be saved using the same filename.  If you choose No, then you will be prompted to enter a new filename for the template. 

Nested Custom Table Entities in a Template  

If there are Custom Tables which have a relationship, the template can include the parent custom table fields and all of the related child custom table 
fields.  There are only a couple of steps involved in creating a table that contains a list of related child records. 

Create a new table in Microsoft Word that contains exactly two rows and however many columns you want with one column per field you want to 
merge. 

In the first row, you need to specify which field should be merged into each column. You do so by using the following format: 
Designer.[TABLENAME].[FIELDNAME]
You must always start with the word Designer followed by a period. Specify the table you want to merge in followed by a period. Specify the field name. 
Example: Designer.Services.Duration where Services is the name of the table and duration is the field that you want to place into that cell.

See also

Applying Preconfigured Template 
Managing Tables 
Managing Custom Table Screens 
Migrating Data 
Importing Data 
Managing Schema 
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Home > Administrator Functions > Managing Schema 

Managing Schema
TopLine Designer allows the administrator to create custom tables, fields, screens and scripts in a test environment without affecting production.  Once 
the project has been fully built and tested, the administrator can export the TopLine Designer settings and apply them to one or many production 
databases.  Only settings will be applied; no test data will be copied to production.

Articles in this section

See also

Applying Preconfigured Template 
Managing Tables 
Managing Custom Table Screens 
Migrating Data 
Importing Data 
Managing Word Templates 

 
Exporting Schema 

Changes 

 
Importing Schema 

Changes 
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Exporting Schema Changes
Exporting TopLine Designer Schema can be located on the Define Fields Windows.

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

   
3. Click the Export Schema link.
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4. From the Export Schema dialog window:

- Select the Custom Table Entities 
- Select the other ACT! items to include 
- Enter the Filename for the export 
- Give a description 

 
5. Click OK to close the Define Fields Window.

See also

Importing Schema Changes 
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Home > Administrator Functions > Managing Schema > Importing Schema Changes 

Importing Schema Changes
Importing TopLine Designer Schema can be located on the Define Fields Windows.

 

1. Open ACT! 
2. Click on the Tools menu and select Define Custom Tables...

   
3. Click on the Import Schema link.
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4. A File Explorer window will appear.  Browse to the location of the Schema file and click Open.

 
5. Several ImportLog windows will appear displaying the import progress.  When finished, a success alert will appear.  Click OK to continue. 

 
6. Then newly created custom tables and fields will now be visible. Click OK to close the Define Fields Window.

See also

Exporting Schema Changes 
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Home > End User Functions 

For the ACT! Windows user:

● View tables interactively, go to the corresponding contact, company or group. 

● Drill down on custom tables to access the detail view. 

● Create a contact, company or group lookup. 

● Click to sort or filter in the list view. 

● Create robust queries and apply date ranges. 

● Perform advanced calculations among fields and in the list view. 

● Create activities or histories based on custom-table fields.  

● Generate email notifications. 

● Modify field appearance (auto hide, change color) based on conditions. 

● Drag and drop fields to group and organize your custom lists. 

● Organize, sort or query your documents. 

● Export list views to MS Excel. 

● Merge custom-table fields into MS Word to create documents and templates.  

● Synchronize your customizations and data. 

● Integrate with TopLine Dash for enhanced reporting and graphical views. 

● Automate your Excel or PDF custom table reports using TopLine Dash Alerts.

Articles in this section

See also

Welcome 
Installation 
Administrator Functions 
Windows vs Web Functionality 
Integration with TopLine Dash 
FAQ 
Videos 
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Using Lookups 
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Home > End User Functions > Using Designer Tabs 

Using Designer Tabs
TopLine Designer Custom Table data is displayed as a tab under the Contact, Company or Group layout (as controlled by the ACT! Administrator) and are always right of the static tabs.  Tab names 
are controlled by the Screen names.

See also

Using List View 
Using Lookups 
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Home > End User Functions > Using Designer Tabs > Managing Display Columns 

List Views in TopLine Designer
This opening paragraph should describe the feature that you are documenting. Explain how it is commonly used and what the benefits are. For example: The Widget Master email link allows 
you to easily send information about each widget to various departments within your company. Often, the feature that you are documenting can be best explained by walking the reader 
through step by step. Use screenshots to illustrate the steps where possible.

1. Click on the blue columns icon.

 
2. Use the left and right arrows in the middle of the dialog box to add and remove columns from the view.  User the up and down arrows on the right of the dialog box to change the 

order of the columns. Click OK when finished.

 
3. The new view appears with the selected columns in the selected order.

See also

Adding / Deleting Entities 
Grouping / Filtering 
Replace Values 
Exporting to Excel 
Merge to Word 
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Home > End User Functions > Using Designer Tabs > Replace Values 

Replace Values
Values can be replaced in multiple Custom Table records.

1. Highlight the row (or rows using CNTL-click), and then right click to display the context menu.  Selelct Replace Values. 

 
2. The Replace dialog box will appear.  Select a method (Replace or Append), a field and enter a value.  Click OK.

 
3. The new values will appear in the tab.

See also

Adding / Deleting Entities 
Managing Display Columns 
Grouping / Filtering 
Exporting to Excel 
Merge to Word 
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Home > End User Functions > Using Designer Tabs > Exporting to Excel 

Exporting to Excel

Export to Excel.

1. Select either the Tabd view or the list view. Note that the Export to excel will keep the settings you have from sorting, filtering, columns, and grouping as well. 

 
2. On the startup screen, click the... 

 
3. Data from tab appears in an Excel spreadsheet.

See also

Adding / Deleting Entities 
Managing Display Columns 
Grouping / Filtering 
Replace Values 
Merge to Word 
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Home > End User Functions > Using Designer Tabs > Merge to Word 

Merge to Word

With TopLine Designer MS-Word Merge Integration can: 

Merge to a template to Word 
Merge directly from a row

Using the controls to merge a document to Word

Creating or editing an existing template
Note that the Contract template has a different extension .adtd it is important to create your template from a new one. It is also important to choose the correct list (or table-subentity) if you do not Topline Designer 
will attempt to create a merge in a document that does not contain any of the fields and an error will occur.

TopLine Designer allows you to create merged documents from the following fields in the same documents: Contact, Company , Group fields and from the fields in the list view sub-entity that you are in and from fields 
of a subentity related to the one that you are in. (You can also select fields from another list provided that the sub-entity has a child relationship to the sub-entity list.) 
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Mail Merge to an embedded grid; Creating a table of child records

There are only a couple of steps involved in creating a table that contains a list of related child records.

1.    Create a new table in Microsoft Word that contains exactly two rows and however many columns you want with one column per field that you want to merge. 

2.    In the first row, you need to specify which field should be merged into each column.  You do so by using the following format: 
Designer.[TABLENAME].[FIELDNAME]
You must always start with the word Designer followed by a period.  You then specify the table that you want to merge in followed by a period.  You then specify the field name. 

Example: Designer.Services.Duration where Services is the name of the table and duration is the field that you want to place into that cell.

Inside word you can also embed a list in a table with the content of child sub-entity list. 

Mail Merge from multiple record rows and into separate documents

You can highlight multiple rows and mail merge each row to a separate word document.
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Tips: Using MS-Word merge always close MS-Word using file close to avoid the Normal.dot message warning. 

See also

Adding / Deleting Entities 
Managing Display Columns 
Grouping / Filtering 
Replace Values 
Exporting to Excel 
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Using the List View
The List View in TopLine Designer allows you to see all the fields that are available in the sub-entity or Tab. In this example below, we selected the Contract List View from the drop down menu View. 
Note that using list view is no different then using Designer Tabs, only now do you see all records for that sub-entity in the database. All the controls for Adding/Deleting Entries are the same, Displaying Columns, 
Grouping and Filtering as well as Exporting to Excel and using Merge to Word.

Selecting Contract Lists will show the list below:

 

  This section is identical to Using Designer Tabs please refer to that section      
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a.     Adding 
                    Click Add to create a new items to the list. You will be prompted to a new blank form. It is preferable to do so from the contact, company or group so as to automatically pre-populate the corresponding 
fields.      

 b.    Deleting 
                    Select any row and click on the delete icon (Red X)
       

c.    Choosing Columns 
                    In order to view more fields in the list view, select the field from the left column and bring to the right. (See Below) 

      

 d.    Exporting to Excel 

Exporting to Excel sends all the visible rows and columns to excel.  If you have applied a group based on a field, MS-Excel will show those results as well.The same is true if you applied a filter; only the filtered data will 
show in the list view.

       

e.    Merging to Word - Please refer to the MS-Word Mail Merge section for more details. 

1. Merge an existing template to Word

2. Create a new template

3. Edit an existing template

4. Mail Merge multiple rows to an embedded grid

5. Select multiple record rows and mail merge to separate documents the content of each record

f.    Printing
Select the print icon and print a list directly to your printer.

 
g.   Grouping 
Click on group and Drag a field to the space created between the the icons and the list - Refer to the Grouping and Filtering section under Using Designer Tabs. 

 

See also

Using Designer Tabs 
Using Lookups 
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Home > End User Functions > Using Lookups 

Look-ups 

If you have checked the custom table to be viewable in TopLine Designer, you will be able to go to the Look-up menu. 

You can select the custom table name and the associate custom table fields to look-up the contents and return the resulting contacts, companies or groups.  

This is a unique feature in TopLine Designer and the Look-up is not just limited to contacts (see below the 5 options available: Contacts, Companies, Groups, Contacts At Companies, Contacts Within 
Groups).

 

1. Contacts

This return the Look-up we are all familiar to when we look-up a contact field in ACT! 
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the results are Contacts

2. Companies

This Returns the Look-up we are familiar to when we look-up Companies in ACT!, e.g.  

the results are Companies 

3. Groups

This Returns any Group records link to the search criteria, the results are groups

4. Contacts At Companies

This Returns all the Contacts at the Companies linked to our search within the custom table,

 the results are Contacts

 
123 . End User Functions

 
TopLineDesigner



5. Contacts Within Groups

This Returns all the Contacts within all Groups linked to our search, the results are contacts belonging to these groups

See also

Using Designer Tabs 
Using List View 
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Home > Windows vs Web Functionality 

Windows versus Web Functionality
The following functionality is available with TopLine Designer on ACT! Premium and available with TopLine Designer on ACT! for Web. 

1. You can view a total of 10 Tabs at the contact level, company level, group level 
2. You arrange the columns to view any field in the custom table 
3. You can double click and view the content of each Tab as it was designed in the Windows client on the server 
4. You can sort by any field 
5. You can edit and save the new content of almost all the fields in the custom table 
6. You can add or delete a row or record under any Tab or in the List view 
7. You can see an embedded table in the screen view and drill down on the content of the sub-custom child table  
8. You can generate a list of each custom table in a List view and further arrange columns, sort by field and drill down from the list view, delete or add new records 

Below is an example of a comparison for a Project Module in Windows and in ACT! for Web:

Windows:

Web:
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Windows:

Web:
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The following features are not available on the Web: Create a look-up, Grouping, Filtering, Exporting, Replacing Values, Merging to Word, Importing Data, as well 
as managing the tables such as table creation, field creation and security assignment, scripting in ACT! for web does not apply, as well as using fields to link 
activities, opportunities, or track documents using a URL.

 

See also

Welcome 
Installation 
Administrator Functions 
End User Functions 
Integration with TopLine Dash 
FAQ 
Videos 
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Home > Integration with TopLine Dash 

TopLine Dash Integration
TopLine Dash is the easiest way to create a powerful report in ACT! . In order to be able to leverage this interactive reporting tool you must first own a license of TopLine Dash. You may already have purchased a license which is installed on 
your computer If that is the case, make sure you run version 7 and above. In this example, we will show you version 7.5 which is soon to be released (May 2009). If you purchased TopLine Designer Plus instead of TopLine Designer, you 
would have received a license for TopLine Dash which runs only in ACT! for Windows.

Because each Subentity in ACT! can be created by an ACT! Administrator, we do not have specific dashboard templates available.  Instead, you have to create your own.  

First Click on TopLine Dash Icon in ACT! (Top Right) 

 

 

1. Click  on the New Dashboard Icon.

 

 2.Select Custom Sub-Entity  3. Now select which custom table to report. 

Once you have selected the correct custom table you can create 2 filters: one for a date field and one from a general field (all other fields can be used as filters inside any ultralist view) 

These 2 filters will be used and reflected in the graphical views generated in the TopLine Dash.
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Next you can filter from within the list view. After you select to view the ultralist, using the filter icon next to each field, you can now filter your dashboard for any fields in the view. Note the Sigma Letter allows you to add statistics to the 
view below.

While Filters can be saved when you save a new dashboard, stats are not. You can if you want to export your dashboard to excel. 

 

You can choose, in the dashboard, from any fields in the custom entity (Assets in this example) or the contact, company or group fields. This feature makes the dashboard very powerful as you can view any parent custom tables if there 
was one above asset.
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Below are dashboard created for Custom Entities:

Below are the filters Setting for the two panels:

Below is the filter.
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Please review the TopLine Dash Help file for further assistance.

See also

Welcome 
Installation 
Administrator Functions 
End User Functions 
Windows vs Web Functionality 
FAQ 
Videos 

 
131 . Integration with TopLine Dash

 
TopLineDesigner



Home > FAQ 

Articles in this section

See also
Welcome 
Installation 
Administrator Functions 
End User Functions 
Windows vs Web Functionality 
Integration with TopLine Dash 
Videos 

 
Purchase and 
Licensing FAQ 

 
Installation FAQ 
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Home > FAQ > Purchase and Licensing FAQ 

FAQ 
1. I need multiple licenses of the TopLine Dash and TopLine Designer.  What are my quantity discounts?

2. Do I need to buy a license for ACT! for Web?

TopLine Designer comes with a license for Windows and a license for the Web for that same user. Each user needs a license.  

While TopLine Designer for ACT! for Windows will work on multiple databases, a license for ACT! for Web can only work on one database at a time. You must use the Web License 
Manager in the Start menu to free up or set-up the use of TopLine Designer ACT! for Web for a user. 

3. How do I order TopLine Add-ons 

a. Order on the TopLine eStore: https://store.toplineresults.com/ 

Note that the eStore only allows for one level of quantity discounts, therefore, for larger quantities (20 and above) you should request our order form. 

b. You can download our order form from https://store.toplineresults.com/addons_orderform.pdf 

and fax it to us at the number on the form.

c. If you are an ACC you may qualify as a reseller and receive a coupon for your orders.

d. Call 800-880-1960 to request a quote  

 4. What is the difference between TopLine Designer and TopLine Designer Plus?

TopLine Designer Plus includes a license of TopLine Dash Manager and TopLine Designer.

5. Can I upgrade from TopLine Designer 2.0 to TopLine Designer 3.0

Yes and it is free!  Go to our Download area: http://www.toplineresults.com/products/downloads.htm 

6. Do I need to buy an Admin version of TopLine Designer?

No, there is not a TopLine Designer Admin Version or runtime version.  When you buy TopLine Designer, you receive the license for a user alongside an administrator user 
included. An ACT! Administrator or Manager will have access to the TopLine Designer Administration area. A standard user will still need a license to view the tables, but will not be 
able to access the admin area also called TopLine Entity Manager area. 
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See also

Installation FAQ 
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Home > FAQ > Installation FAQ 

TopLine Designer
1. Where do I download the latest version of TopLine Add-ons? 

Go to http://www.toplineresults.com/products/downloads.htm 

2. Should I uninstall before I upgrade?

It is recommended to uninstall any previous version of TopLine add-ons prior to upgrade. 

3. If I uninstall TopLine Designer, will affect the data in the table?

No 

4. If I uninstall TopLine Dash, will I lose my dashboard?

Version 5 and below: Yes

Version 6 or 7: No

5. How do I get support for TopLine add-ons: 

TopLine Designer does comes with numerous free videos available from the Website.
TopLine Designer provides with a blog: http://blog.toplineresults.com/  
TopLine Designer provides an on line helpfile.
TopLine Designer also provides a 30-day fully functional trial version. 

6. To guarantee a proper installation, it is best to get professional help from your ACT! CC.
ACT! CC's are experts at ACT! Database Development and can help your company make a leap in performance with ACT! 

7. If you just purchased TopLine Add-ons within 30-days directly from TopLine please email support@toplineresults.com.  
If you do not have an ACT! CC, or do not know, please contact TopLine Results.

See also

Purchase and Licensing FAQ 
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Home > Videos 

Articles in this section

See also
Welcome 
Installation 
Administrator Functions 
End User Functions 
Windows vs Web Functionality 
Integration with TopLine Dash 
FAQ 

 
User Videos 

 
Advanced Webinar 

Videos 
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Home > Videos > User Videos 

User Video
Please refer to our videos for a quick review: http://www.toplineresults.com/products/toplinedesigner/videos.htm 

 

See also
Advanced Webinar Videos 
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Home > Videos > Advanced Webinar Videos 

ACT CC Videos
Please refer to our Webinar videos for advanced examples of TopLine Designer integration and administration 

Introducing TopLine Designer v2.0 
June 28, 2008 

Effective Database Designs using TopLine Designer. 
February 10, 2009 

Schema and Data Imports with TopLine Designer 
February 17, 2009 

TopLine Designer Scripting 
February 24, 2009 

TopLine Designer : A closer look at Projects and Customer Service 
March 3, 2009 

Powerful Reporting on Custom Tables 
March 10, 2009 

 

See also
User Videos 
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